"Override Do Not Disturb" Setting Issue

Boz1

Well-known member
HoFo Member
Joined
Aug 28, 2006
Messages
16,768
Carrier(s)
Google Voice; T-Mobile Postpaid Mobile Data; FreedomPop; FreeUp; Dent; 3UK
Device(s)
Pixel 3a XL; Moto E4; LG Phoenix 2
When I have my GV app set to
Settings > Incoming call notifications (For incoming Voice Wi-Fi calls) > Override Do Not Disturb [ENABLED]
(and Do Not Disturb is enabled) my Pixel 3a XL only vibrates for incoming calls to my GV #.

Is there any way to get it to both vibrate and play the set "Sound" (GV ringtone)? Both ringtone and vibration happen for incoming calls when Do Not Disturb is OFF.

Is this a problem with the GV app, or is it a Pixel 3a XL specific problem?

If somebody knows, or could test this on their phone, I'd appreciate feedback. Thanks!
 
Last edited:
I'm not very familiar with GV. I have it on my iPhone at the moment for a potential port of number thing.

I don't see a setting for incoming call notifications that overides do not disturb. I don't see it on Samsung either.

Do not disturb just seems to send calls to vm.
 
There is some stuff here.

I don't know if that is helpful.
 
There is some stuff here.

I don't know if that is helpful.
Thanks, but that seems to be a different issue. That question is trying to override DND for a single contact, and not about the setting I'm asking about.
 
Thanks, but that seems to be a different issue. That question is trying to override DND for a single contact, and not about the setting I'm asking about.

Yeah I kinda thought so. You got screenshots that show what you are talking about? Because it doesn't seem to exist on my phones.

Looks like it might be a Pixel thing.
 
I'm not very familiar with GV. I have it on my iPhone at the moment for a potential port of number thing.

I don't see a setting for incoming call notifications that overides do not disturb. I don't see it on Samsung either.

Do not disturb just seems to send calls to vm.
Perhaps it only shows up if the GV app is set to "Prefer Wi-Fi and mobile data".
 
Perhaps it only shows up if the GV app is set to "Prefer Wi-Fi and mobile data".

That doesn't change anything.
 
Last edited:
You can make those images a little smaller by selecting them and resizing the corners. Note: You may want to edit them.

I don't have this in Samsung or iPhone:

ok.JPG
 
Last edited:
This is Samsung A53

Screenshot_20240604_164316_Voice.jpg



This is iPhone SE3

IMG_0808.PNG
 

I assume when you say (and Do Not Disturb is enabled), you mean in the GV app.

Is there a sound and vibration settings? I guess to check the sound? or the ringtone?

I don't have my Pixel 6a anymore.

I guess on my iphone i could set a global do not disturb through the Focus thing and allow the GV app to get calls.
But that's affecting all my calls. I don't know..i've never used gv.
 
Last edited:
I assume when you say (and Do Not Disturb is enabled), you mean in the GV app.

Is there a sound and vibration settings? I guess to check the sound? or the ringtone?

I don't have my Pixel 6a anymore.

I guess on my iphone i could set a global do not disturb through the Focus thing and allow the GV app to get calls.
But that's affecting all my calls. I don't know..i've never used gv.
No, I mean DND for the phone. The "Override Do Not Disturb" GV app setting IS working, at least to an extent, since with that enable, the phone DOES vibrate for incoming GV calls. Yes, within that setting I have both sound and vibrate enabled, but it still only vibrates. It may just be an issue with my old phone. I'll keep fiddling with it. Thanks for your input!
 
How do I DELETE a post on the new forum? Lol!
 
How do I DELETE a post on the new forum? Lol!

You used to be able to but you can't anymore as of 2 or 3 days ago. I've gotten burned by it a few times lol.
 
No, I mean DND for the phone. The "Override Do Not Disturb" GV app setting IS working, at least to an extent, since with that enable, the phone DOES vibrate for incoming GV calls. Yes, within that setting I have both sound and vibrate enabled, but it still only vibrates. It may just be an issue with my old phone. I'll keep fiddling with it. Thanks for your input!

Oh ok. Yeah I don't know how GV is used.

So I've turned on DND on my iphone and allow GV to get notifications.

... IMG_0812.PNG. ....... IMG_0811.PNG .... IMG_0813.PNG

With it set to Prefer Wi-Fi and mobile data.

I have haptics (vibration) set to off.

And I received calls to the GV number fine with ringing. If that is what you mean.
 
Basically, on the iPhone anyway, it seems that you allow GV to overide phone DND through the phone's DND settings in Focus.

And then GV takes on whatever you have set for everyday phone vibration and ringtone in Sounds and Haptics.

I wonder if there is a way in the Pixel phones DND setting to allow GV to receive calls. And then just ignore or disable the allow call to overide DND setting in GV.
 
Last edited:
Well, I guess the ringtone just isn't going to work on my 3a XL. I tried to set one of the default built-in ringtones, instead of using the "Hangouts Call" ringtone I had loaded, but it made no difference. I suppose I should just be happy overriding the phone's DND at least makes incoming GV calls vibrate!
 
Last edited:
Back
Top